HDU 4861 Couple doubi

HDU 4861

Couple doubi

一个水题。 可以随便找规律。

Couple doubi

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 221 Accepted Submission(s): 186

Problem Description

DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,…,k) ball is 1^i+2^i+…+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.

Input

Multiply Test Cases. In the first line there are two Integers k and p(1<k,p<2^31).

Output

For each line, output an integer, as described above.

Sample Input

2 3 20 3

Sample Output

YES NO

Author

FZU

Source

2014 Multi-University Training Contest 1

1^k + 2^k + 3^k + (p-1)^k % p 只有当k|p-1的时候才等于p-1,其余都是0的。 故非零的个数是 k/(p-1) 判断这个是奇数还是偶数就可以了。

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
/* ***************

Author :kuangbin

Created Time :2014/7/22 22:11:38

File Name :E:\2014ACM\比赛\2014多校训练\2014多校1\2014 Multi-University Training Contest 1(标程+数据)\多校第一场(标程+数据)\HDU4861.cpp

************************************************ */

#include <stdio.h>

#include <string.h>

#include <iostream>

#include <algorithm>

#include <vector>

#include <queue>

#include <set>

#include <map>

#include <string>

#include <math.h>

#include <stdlib.h>

#include <time.h>

using namespace std;

int main()

{

//freopen("in.txt","r",stdin);

//freopen("out.txt","w",stdout);

int k,p;

while(scanf("%d%d",&k,&p) == 2)

{

int t = k/(p-1);

if(t&1)printf("YES\n");

else printf("NO\n");

}

return 0;

}
------ 本文结束------
  • 本文作者: kuangbin
  • 本文链接: 279.html
  • 版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明出处!
0%