BZOJ 3224: Tyvj 1728 普通平衡树 (Scapegoat tree)

BZOJ3224 水题一样。 为了练习一下替罪羊树,用这个来搞了一发。 替罪羊树可以不需要旋转来保存平衡。 当然在这题还看不到他的优势。

3224: Tyvj 1728 普通平衡树

Time Limit: 10 Sec Memory Limit: 128 MB Submit: 1956 Solved: 769 [Submit][Status]

Description

您需要写一种数据结构(可参考题目标题),来维护一些数,其中需要提供以下操作: 1. 插入x数 2. 删除x数(若有多个相同的数,因只删除一个) 3. 查询x数的排名(若有多个相同的数,因输出最小的排名) 4. 查询排名为x的数 5. 求x的前驱(前驱定义为小于x,且最大的数) 6. 求x的后继(后继定义为大于x,且最小的数)

Input

第一行为n,表示操作的个数,下面n行每行有两个数opt和x,opt表示操作的序号(1<=opt<=6)

Output

对于操作3,4,5,6每行输出一个数,表示对应答案

Sample Input

10 1 106465 4 1 1 317721 1 460929 1 644985 1 84185 1 89851 6 81968 1 492737 5 493598

Sample Output

106465 84185 492737

HINT

1.n的数据范围:n<=100000

2.每个数的数据范围:[-1e7,1e7]

Source

平衡树

题意很简单。 直接替罪羊树练习了一发。
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
/* ***************

Author :kuangbin

Created Time :2014/9/30 8:13:45

File Name :E:\2014ACM\专题学习\数据结构\ScapeGoatTree\BZOJ3224.cpp

************************************************ */

#include <stdio.h>

#include <string.h>

#include <iostream>

#include <algorithm>

#include <vector>

#include <queue>

#include <set>

#include <map>

#include <string>

#include <math.h>

#include <stdlib.h>

#include <time.h>

using namespace std;

const int MAXN = 200010;

const double alpha = 0.75;

struct Node{

Node *ch[2];

int size,key,nodeCount;

bool exist;

bool isBad(){

return ch[0]->nodeCount > alpha*nodeCount + 5 || ch[1]->nodeCount > alpha*nodeCount + 5;

}

void push_up(){

size = exist + ch[0]->size + ch[1]->size;

nodeCount = 1 + ch[0]->nodeCount + ch[1]->nodeCount;

}

};

struct ScapeGoatTree{

Node pool[MAXN];

Node *tail,*root,*null;

Node *bc[MAXN];//内存回收

int bc_top;

void init(){

tail = pool;

null = tail++;

null->ch[0] = null->ch[1] = null;

null->size = null->key = null->nodeCount = 0;

root = null;

bc_top = 0;

}

inline Node *newNode(int key){

Node *p;

if(bc_top)p = bc[--bc_top];

else p = tail++;

p->ch[0] = p->ch[1] = null;

p->size = 1;

p->key = key;

p->nodeCount = 1;

p->exist = true;

return p;

}

inline void Travel(Node *p,vector<Node \*>&v){

if(p == null)return;

Travel(p->ch[0],v);

if(p->exist)v.push_back(p);

else bc[bc_top++] = p;

Travel(p->ch[1],v);

}

inline Node *divide(vector<Node \*>&v,int l,int r){

if(l >= r)return null;

int mid = (l+r)/2;

Node *p = v[mid];

p->ch[0] = divide(v,l,mid);

p->ch[1] = divide(v,mid+1,r);

p->push_up();

return p;

}

inline void rebuild(Node *&p){

vector<Node *>v;

Travel(p,v);

p = divide(v,0,v.size());

}

Node **insert(Node *&p,int val){

if(p == null){

p = newNode(val);

return &null;

}

else {

p->size++;

p->nodeCount++;

int d = (val >= p->key);

Node **res = insert(p->ch[d],val);

if(p->isBad())res = &p;

return res;

}

}

//插入一个值为val的点

void insert(int val){

Node **p = insert(root,val);

if(*p != null)rebuild(*p);

}

//删除第id个点

void erase(Node *p,int id){

if(p->exist && id == p->ch[0]->size+1){

p->exist = 0;

p->size--;

return;

}

p->size--;

if(id <= p->ch[0]->size+p->exist)

erase(p->ch[0],id);

else erase(p->ch[1],id - p->ch[0]->size - p->exist);

}

//查询小于val的数的个数+1

int rank(int val){

Node *now = root;

int ans = 1;

while(now != null){

if(now->key >= val)now = now->ch[0];

else {

ans += now->ch[0]->size + now->exist;

now = now->ch[1];

}

}

return ans;

}

int get_kth(int k){

Node *now = root;

while(now != null){

if(now->exist && k == now->ch[0]->size+1)

return now->key;

else if(now->ch[0]->size >= k)now = now->ch[0];

else {

k -= now->ch[0]->size + now->exist;

now = now->ch[1];

}

}

}

//删除一个值为val的点

void erase(int val){

erase(root,rank(val));

if(root->size < alpha*root->nodeCount)

rebuild(root);

}

}tree;

int main()

{

//freopen("in.txt","r",stdin);

//freopen("out.txt","w",stdout);

int n;

while(scanf("%d",&n) == 1){

tree.init();

int op,x;

while(n--){

scanf("%d%d",&op,&x);

if(op == 1)tree.insert(x);

else if(op == 2) tree.erase(x);

else if(op == 3)printf("%d\n",tree.rank(x));

else if(op == 4)printf("%d\n",tree.get_kth(x));

else if(op == 5)printf("%d\n",tree.get_kth(tree.rank(x)-1));

else printf("%d\n",tree.get_kth(tree.rank(x+1)));

}
}
return 0;

}
------ 本文结束------
  • 本文作者: kuangbin
  • 本文链接: 415.html
  • 版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明出处!
0%